Change the MAC address on the vlan interface

I needed to change MAC address of the vlan interface for my router. According to https://wiki.mikrotik.com/wiki/Change_MAC_address_of_VLAN_interface you need to create a bridge for that

In the following example wan is a vlan interface that needs to be changed MAC

/interface bridge add name=bridge_wan disabled=no
/interface bridge port add bridge=bridge_wan disabled=no interface=wan

Then need to re-configure the IP address to use the bridge_wan interface instead of wan Since in my case I use DHCP client for that interface, I need to setup the DHCP client to use the bridge interface:

/ip dhpc-client add disabled=no interface=bridge_wan

To reset the MAC address use the following command:

/interface bridge set bridge_wan admin-mac=de:ad:00:be:ef:00 auto-mac=no

To reset back to the original MAC use the following command

/interface bridge set bridge_wan auto-mac=yes